386BSD 0.0 boots!

386BSD 0.0

386BSD 0.0

After years of chasing this thing, and being so late to the party, I’ve done it.

I’ve installed 386 BSD 0.0

It’s 2am and I’m exhausted.

vi isn’t there, but elvis is; I’ve left the building.

This entry was posted in 386BSD, bochs by neozeed. Bookmark the permalink.
avatar

About neozeed

What is there to tell? I've loved UNIX like things since I was first exposed to QNX in highschool (we had the Unisys ICONS!), and spent the better time of my teenage years trying to get my own UNIX... I should have bought Coherent in retrospect.. Anyways latched onto Linux in 1992, and then got some old BSD admin books and have been hooked on the VAX BSD & other big/ancient things since...!

8 thoughts on “386BSD 0.0 boots!

  1. it's interesting how you always seem to be fascinated with earlier and earlier versions. i'm usually interested in the last stable of everything. might be because i'm an archiver-type and a mental completionist.. : )

    are you planning on doing 386bsd 1.0?

  2. I don't know I may do that one, although I figure it'll require me to do a bunch of work from dumping the filesystem, and probably building a kernel outside of itself….

    for me, the largest factor is some 'bug' in flow control in qemu/slirp that makes downloading EXTREMELY slow, however uploading from httpd is super fast.. go figure.

  3. No, I haven't seen a good source of minix 1.x stuff, but then I haven't looked too hard either. I should also check that wayback machine for that uclinux that ran on the Atari ST….

    • I dont remember, I think I just kept on running it, or just ran ‘make’ … maybe I commented that phase out of the makefile, I forget…

      But 0.0 was pretty ‘broken’ as it was basically in ‘it booted’ status, there was a lot of people who helped to make it into 0.1 status.. esp with working multiuser support which 0.0 lacks.

      The fact you can even boot 0.0 is a major milestone.

  4. I just realized the bochsrc I had used didn’t have the disk definition in there, so I’ve corrected that. I’m using BOCHS 2.4.5 if it maters.

Leave a Reply

Your email address will not be published.

Notify me of followup comments via e-mail. You can also subscribe without commenting.