Qemu 1.6.0 pre-3 OS X binaries

I’ll do a release version later, but for those who want it, the i386 & PowerPC emulators.

On the i386 side, I did notice that with an older glib2 installed in /usr/local/lib that Qemu was slow, buggy and all around crappy.  But with a newer lib I’d recently built on my MacPro, it works fine, along with SOUND (tested with DOOM).  So yeah test with the i386 version first, I included the demo DOOM v1.1, and see how that works for you.  I’ve included the libintl & pixman libraries, along with a tar of my glib2 install.  Backup & replace as necessary.

It runs fine on my laptop, which up until now hasn’t run Qemu.

Qemu on OS X 10.8.3

Qemu on OS X 10.8.3

 

This entry was posted in OS X, qemu by neozeed. Bookmark the permalink.
avatar

About neozeed

What is there to tell? I've loved UNIX like things since I was first exposed to QNX in highschool (we had the Unisys ICONS!), and spent the better time of my teenage years trying to get my own UNIX... I should have bought Coherent in retrospect.. Anyways latched onto Linux in 1992, and then got some old BSD admin books and have been hooked on the VAX BSD & other big/ancient things since...!

7 thoughts on “Qemu 1.6.0 pre-3 OS X binaries

  1. I know it’s unrelated to that, but… so you got a MacBook Air? Nice! 🙂

    As a sidenote, I noticed that at least my build of Qemu 1.6.0 (64-bit Linux) won’t run the MIPS firmware necessary for NT anymore, I just get a black screen. Returning to 1.5.2 fixes that but I can’t get anything to install. I wonder if it’s just my build or if something broke on the way to 1.5.

    • Yeah I picked up the cheap MacBook Air before I began my Odyssey that led me to Hong Kong. I wanted something light, with a full keyboard… I’ve been pretty happy with it so far.

      I haven’t tried to run MIPS NT in a while, I guess it may be worth taking a look. Hervè kind of dropped off the face of the earth so asking him isn’t probably going to work. Then again he was about to have a 2nd kid so…. I think we all know how the real world gets in the way of this kind of thing from time to time.

  2. Curious to know which version of glib2 you’re using. I’ve just built 1.6.0 release on rhel6 which I think is slow. I have version 2.22.5.

  3. I just discovered your post where you removed the fullscreen/resize on v 1.1.1 – applied this to 1.6.0 which improves things no end!

Leave a Reply

Your email address will not be published.

Notify me of followup comments via e-mail. You can also subscribe without commenting.