Research UNIX v9

v9 on TME

This just in, I have just booted Research UNIX v9 on TME’s SUN-3 emulator!

And there we are booted up and logged in.. pardon the disk error..

funinthe

I’m slightly hesitant about uploading it, as it clearly isn’t right… And this is only the binary component, I have integrated the source tree onto the disk image.  But I haven’t actually tried to compile anything except a simple hello-world program.  You can download it here from sourceforge: SUN3-research_v9.7z  If anyone want’s to browse the source, it’s on my CVS browser thing.

This entry was posted in 68020, SUN, unix and tagged , by neozeed. Bookmark the permalink.
avatar

About neozeed

What is there to tell? I've loved UNIX like things since I was first exposed to QNX in highschool (we had the Unisys ICONS!), and spent the better time of my teenage years trying to get my own UNIX... I should have bought Coherent in retrospect.. Anyways latched onto Linux in 1992, and then got some old BSD admin books and have been hooked on the VAX BSD & other big/ancient things since...!

10 thoughts on “Research UNIX v9

  1. I can’t get tme to compile on linux 16.04, even following the guide. I keep getting errors along the lines of:
    /usr/bin/ld: /usr/lib/gcc/x86_64-linux-gnu/5/../../../x86_64-linux-gnu/libgtk-x11-2.0.so: undefined reference to symbol ‘g_source_remove’
    /usr/lib/gcc/x86_64-linux-gnu/5/../../../x86_64-linux-gnu/libglib-2.0.so: error adding symbols: DSO missing from command line
    collect2: error: ld returned 1 exit status

    • You are proably using someting far far too new. That’s why I was using Debian 4… Linux/GTK is far too unforgiving when it comes to code drift. Also I built it for the x86, not the x64, as I wasn’t even sure if it was 64bit friendly.. In my dump file I did include a binary

      • Indeed someone should port it to FLTK…

        TME seems to emulate accurately… but it is quite flaky to get running.

    • I’ve had plenty of disk issues stressing the system… And I wanted to get stuff like the source in, which I’ve fixed in the latest 30MB version. Nothing too scary.

  2. My first real Sun computer was a Sun 3-/180 full height 19-inch rack with two super eagle 575MB drives. I had to fire one drive up, let it spin up, then the second, let it spin up, and then finally the CPU, any other order and it would trip a 20 amp breaker.

    Now I am trying to get SunOS 4.1.4 running on a qemu sparc emulator. When I try to partition the drive, it fails to write saying drive is unformatted. If I attempt to format,
    it fails. Not sure how to get past this.

Leave a Reply

Your email address will not be published.

Notify me of followup comments via e-mail. You can also subscribe without commenting.