PC-MOS/386

PC-MOS/386 print ad

PC-MOS/386 print ad

PC-MOS/386 was another multi-user MS-DOS Operating system. And they had some great ads, like above.

I was able to track down a few disks but of them all only the version 5 one seemed to run to some degree under Qemu. Or at least the $386.sys memory driver.

pc-mos 1.02

pc-mos 1.02

This is about as much as I got out of PC-MOS/386 1.0

pc-mos 3.00

pc-mos 3.00

While PC-MOS/386 3.0 loads, if you try to load the protected mode $386.sys driver it just hangs.

pc-mos 5.01

pc-mos 5.01

And PC-MOS/386 5.0 not only loads, but will load up with the protected mode driver on Qemu.

pc-mos 5.01 protected mode

pc-mos 5.01 protected mode

I’ve managed to get a serial ‘terminal’ to run, and for anyone who ever needs the hint, here is the config.sys, autoexec.bat and user01.bat file to make it boot up…. Neither VirtualPC, nor VMWare can boot up with the drivers.

config.sys

memdev = \mos\$386.sys /p
device = \mos\pcterm.sys
device = \mos\$serial.sys /ad=03f8,in=4,hs=x,ib=2048,ob=2048
smpsize = 80k
buffers = 40

autoexec.bat

echo off
rem
rem turns dot prefix command syntax off
rem
rem
rem issue path command
rem
path c:\;c:\mos
rem
rem configure for terminal(s), each addtask line is for a terminal…
rem
addtask 300k,1,,user01,pcterm,1,19200
rem addtask 300k,2,,user02,pcterm,3,19200
rem addtask 300k,3,,user03,pcterm,4,19200
rem addtask 300k,4,,user04,pcterm,5,19200
rem
rem set up printer
rem
addtask 032k,6,,printer
rem
rem make print spooler directory, note this example uses a
rem virtual disk.
rem
rem md d:\spool
rem
rem issue command for spooler
rem
spool c:\spool\ /t05
rem
rem define operating system prompt
rem
prompt $h0$p $

user01.bat

path c:\;c:\mos
prompt $h1$p $a
spool c:\spool\ /t5

So what is it like? Under emulation lots of keystrokes are lost, and it feels slow. I’m sure it’s a COMPLETELY different story on actual hardware. PC-MOS 5.0 also cannot run DPMI programs, which is a shame. Then again DPMI was a ‘new and exciting’ thing in 1992 so I guess it’s not that surprising. I’m not aware of any support to run Windows 3.1 but again 1992 was when the tide really started to turn to Windows.

As they mention on wiki memory costs, and slow disks of the time certainly made things like PC-MOS really slow.