How to fix weird mouse issues with VM’s migrated from MS Virtual PC/Virtual Server/Hyper-V

I had this issue with one VM where the mouse would either play dead, or it’d just hide in a corner.  While I did have RDP access, it was.. quite annoying.

So some googling around I found this.

1. Do it all over again, but make sure to uninstall the Virtual Machine Additions before you convert the machine.
2. Install VMWare tools without the mouse driver (choose custom installation)
3. Open regedit, and use your mad keyboarding skillz to navigate to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318}
..then remove the value “msvmmouf” and any adjacent spaces from the Regvalue UpperFilters, leaving whatever else is there, then reboot.

And it actually worked!

Security update for Virtual PC/Virtual Server

The articles from Microsoft are available here and here.  It sounds like some good fun….

FTA:

This security update resolves a privately reported vulnerability in Microsoft Virtual PC and Microsoft Virtual Server. An attacker who successfully exploited this vulnerability could execute arbitrary code and take complete control of an affected guest operating system. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

I know I’ll be updating all my machines…!

Standalone Virtual Server annoyances

Ok, Ive been out of the country for a while… lots of fun!

At anyrate, I’ve installed Virtual Server 2005 R2SP1 on my parents computer to give it a good shake down. The good part is that it support’s DVD iso images! Woohoo!

The bad part is that for the most part you’ll get access errors when trying to use it. The only way I’ve figured out how to setup the thing, is to first configure IIS to not allow anonymous users, use the ‘built in security’. Next you’ll have to tell IE that on ‘trusted’ or ‘local’ zones you should have it pass the security automatically. That’ll get you to the configuration page. The next hurdle is that it wont let you start a remote console..

You’ll have to go into the virtual server security setup, and explicity add your user in there with full rights. The administrators group isn’t enough.

With all that out of the way you should be good to go now!