So a few things …

So after this comment, I decided to put a SIMH VAX running 4.3 BSD.  Back in the day, I used to keep a bunch of legacy systems online for the heck of it.  Although I don’t think it ever really took off.. But yeah I figured I should get something back online.

So this time I thought I’d make it somewhat.. different.. So anyways if you feel so inclined go ahead and telnet to

mud.superglobalmegacorp.com

And from there you can create a user account on the mud, and then it’ll create a user in the operating system.

 

I’ve loaded up a bunch of 3rd party stuff.. And since we are living in the past I managed to get the old news reader ‘rn’ to talk to olduse.net  The first time it runs it’ll complain a bunch but there isn’t much you can do except enjoy the ride.

Lynx is present but.. downloading stuff kind of stalls.

All I ask is you play nice.

I’ve added in the flash telnet app.

This entry was posted in 4.3 BSD, mud, SIMH by neozeed. Bookmark the permalink.
avatar

About neozeed

What is there to tell? I've loved UNIX like things since I was first exposed to QNX in highschool (we had the Unisys ICONS!), and spent the better time of my teenage years trying to get my own UNIX... I should have bought Coherent in retrospect.. Anyways latched onto Linux in 1992, and then got some old BSD admin books and have been hooked on the VAX BSD & other big/ancient things since...!

10 thoughts on “So a few things …

  1. it seems the machine is up, but there’s no mud, it just wants me to log in.. tried guest/guest just in case but.. no.

    so i hereby humbly request shell access.

      • thanks. : ) to be honest, i’m trying to copy what you have done, and wanted to duplicate some of the tricks you did, that’s why i asked (and to have some fun while commuting).

        one question: how did you manage to get simh on the internet? no matter whether i try vde or tun/tap, simh always complains about ‘non-existent device’, even though it’s right there. tried running as root (lol) but no success.

        here’s what i did:

        prior to starting simh:
        sudo tunctl -t tap0
        sudo ifconfig tap0 up
        sudo vde_switch -s /tmp/switch1 -tap tap0 -m 666 &
        sudo ifconfig tap0 192.168.6.1 netmask 255.255.255.0 up

        then in vax780.ini:
        (…)
        attach xq vde:/tmp/switch1/ctl

        result:
        Non-existent device

        and, according to ifconfig, tap0 is alive and well, with an ip of 192.168.6.1, as it should be.

      • Oh, I just directly connected to eth0 The guys that setup my server didn’t do a bridge so I can map the ip”s the nice way, so I just hooked onto eth0. It works well enough for me, I use screen to control the console, and I never expected to connect remotely from the server.

        The other advantage of using eth0, is that my ‘VAX’ has a real public IP address.

      • oh i see. never mind then, i’m off to dig in the documentation and possibly the simh source. : )

        do you mind me ftp’ing a few megabytes to and from my home dir? i don’t want to rack up your bill or something.

      • yeah sorry about that…. my old slirp patches if you only need a single port inbound… In the old MS-Windows days, I’d just install a MS-Loopback interface, and use winpcap to sniff off of that, and it’d work surprisingly well.

      • yeah, sadly, i’m not on windows. and somehow your the version with your slirp patches doesn’t want to compile. it seems it’s some odd lib incompatibility and the dependency hell that comes with it, the usual drill on linux. : /

        anyway, i managed to somehow get tun/tap up and running, so it should be fine now.

      • Ok,… although what flavour of linux hell? on what cpu?

        I should revisit that slirp stuff, it was ages ago I did that. And I’m pretty sure the newer patched out slirp from either Qemu or WinUAE should be nicer.

    • Yeah. I had everything setup nicely and then that German idiot had me shut out of the data centre because he was falsely accusing my windows ce build of nethack of being a virus.

      I just honestly haven’t gotten around to re-building my 4.3 BSD mud thing. And the domain efylon.org ended up expiring. I bought it, and put it back up so there is other ones there.

      If you want to roll your own, the components are on sourceforge.

Leave a Reply

Your email address will not be published.

Notify me of followup comments via e-mail. You can also subscribe without commenting.